Как запустить старые расширения Firefox после выхода версии 57

Mozilla готовится к кардинальным переменам: в ноябре 2017 года система управления расширениями для ее браузера будет полностью изменена.

14 ноября 2017 года выйдет финальная версия Firefox 57: этот релиз браузера порвет с прошлым и начнет настоящую революцию в плане поддержки расширений.

Как было объявлено несколько месяцев назад, Firefox 57 больше не позволит использовать старые расширения, и разработчики должны обновить их, чтобы предотвратить их автоматическую несовместимость: Mozilla делает ставку на то, что Firefox 57 вернется, чтобы получить долю на рынке Chrome.

Для Mozilla это эпохальное изменение, направленное на то, чтобы сделать браузер быстрее и эффективнее.

Уже сегодня, установив последнюю версию Firefox (Firefox 55, только что выпущенный: Firefox 55 ориентирован на виртуальную реальность с WebVR и повышает производительность браузера), браузер Mozilla начал обозначать как «устаревшие» большинство доступных расширений, позволяя при этом нормально операция.

Надо сказать, что при наличии «устаревших расширений» пока не будет возможности воспользоваться конкретными преимуществами внедрения новой многопоточной («многопроцессорной») архитектуры Firefox, позволяющей одновременно поддерживать множество вкладок открытыми с очень высокой скоростью. небольшое занятие с точки зрения оперативной памяти и загрузки процессора.

После середины ноября, когда выйдет Firefox 57, все расширения, не соответствующие новому WebExtension «формат» — в значительной степени совместимы с API для управления расширениями, поддерживаемыми в Chrome и Opera — они больше не будут работать и больше не будут загружаться браузером.

Ситуация улучшилась за последние несколько недель, так как многие разработчики используют модель WebExtensions, хотя большинство расширений Firefox остаются несовместимыми.

WebExtensions не может взаимодействовать с кодом Firefox, что может подорвать его стабильность и безопасность: вот почему Mozilla решила нажать на ускоритель.

Проверьте наличие несовместимых расширений Firefox

Мы сказали, что все «старомодные» расширения больше не будут совместимы с Firefox 57 и более поздними версиями.

Совет: наберите about: addons в адресной строке Firefox.

При этом желтая «метка» с указанием «Устарело» будет отображаться в соответствии с расширениями, которые несовместимы с Firefox 57 и, следовательно, еще не приняли модель WebExtensions.

Как запустить старые расширения Firefox после выхода версии 57

Проверить установленные и используемые в настоящее время расширения можно только после установки Firefox 55 или более поздних версий. В противном случае в предыдущих версиях браузера индикация Obsolete не появится.

Как запустить старые расширения в Firefox

Устаревшие («устаревшие») расширения будут автоматически удалены с выпуском Firefox 57.

Однако для тех, кому необходимо продолжать использовать расширения, для которых версия WebExtension еще не доступна, на данный момент единственный способ продолжить работу — установить Firefox ESR (выпуск с расширенной поддержкой).

Загружаемый на этот адрес, Firefox ESR — это специальная версия браузера, предназначенная в первую очередь для компаний (которые не могут и не хотят постоянно устанавливать новые основные выпуски).

Тем не менее, Firefox ESR всегда обновляется в отношении безопасности и, следовательно, является версией браузера, которая не подвергается никакому риску.

Как запустить старые расширения Firefox после выхода версии 57

Firefox ESR будет поддерживать старые расширения (кроме WebExtensions) до июня 2018 года. По состоянию на 26 июня 2018 года единственной поддерживаемой версией Firefox ESR будет версия, основанная на Firefox 59, которая, в свою очередь, включает только поддержку WebExtensions.

В качестве альтернативы, если вам нужно загрузить старые расширения, вы можете использовать такие браузеры, как Бледная луна е Водяной лис, оба получены из кода Firefox.

Добавить комментарий

Ваш адрес email не будет опубликован.